21 11 / 2013

Have recently discovered that Mongoid support for multi-parameter attributes has been removed in version 4.0. Details can be found in this thread. 

Practically it makes it impossible to use <% datetime_select %> helper.

So I have added Classes from Mongoid v.3.x to enable support back in 4.0 with slight amendments to support Rails 4.0.1:

Also make sure that config.autoload_paths is set in application.rb to load lib/* files